Тема: обновления бух. 7.7

Ответить в теме
Показано с 1 по 7 из 7
  1. Вверх #1

    По умолчанию обновления бух. 7.7

    Подскажите по начислению амортизации в 288 релизе. Бухгалтер говорит что амортизация теперь должна быть равна в НУ и БУ. Но судя по алгоритму, она может быть равна если раньше был прямолинейный метод. А если раньше был налоговый, а теперь стал прямолинейный, то какой срок использования не ставь, всеравно в точности не будет совпадать. Что делать? Как народ сейчас борется с амортизацией?


  2. Вверх #2
    Документ "волшебный" делали??? Он в 287 появился, а 288 стал правильнее работать. Называется "Корректировка остатков ОС в связи с вступлением в действие норм НК". Ищется в журнале с документами по ОС.

  3. Вверх #3
    Конечно делали и перезаполняли. Документ тут не причем. Я спрашиваю по алгоритму начисления амортизации. Что никто не разбирался в этой амортизации? Даже если математически посчитать, сумма амортизации БУ и НУ будет равна только если раньше был тоже прямолинейный метод. Или она всетаки не должна быть равна по НК?

  4. Вверх #4
    В общем случае не должна быть равна (по НОА нал учет может не вестись)
    Реальная проблема в том, что в БУ алгоритм делает расчет по первоначальной стоимости.
    Вместо этого надо по остаточной на 01.04.

    В начислении износа, попробуйте рассчитать остаточную стоимость на 01.04. и использовать ее вместо первоначальной. Что-то вроде следующего получится,
    где ПоОстаточнойСтоимости - новый доп. флаг в документе, если установлен то работать по измененному алгоритму.

    //================================================== ==============
    Функция РассчитатьСрокИспользования(ДатаВвода,СрокИспользо вания)
    Если ПустоеЗначение(ДатаВвода) = 0 Тогда
    Если ДатаВвода < '01.04.11' Тогда
    //учет в НУ ведется с 01.04.2011, пересчитаем Срок использования
    Годы = ДатаГод(ДатаНачНУ)-ДатаГод(ДатаВвода);
    Если Годы < 0 Тогда
    Годы = Годы + 100;
    КонецЕсли;
    Разн = ДатаМесяц(ДатаНачНУ) - ДатаМесяц(ДатаВвода) + Годы*12;
    Если ДатаЧисло(ДатаНачНУ) < ДатаЧисло(ДатаВвода) Тогда
    Разн = Разн-1;
    КонецЕсли;
    // nvk {
    Если ПоОстаточнойСтоимости = 0 Тогда
    Возврат ?(СрокИспользования > Разн,СрокИспользования - Разн,0);
    КонецЕсли;
    // nvk }

    КонецЕсли;
    КонецЕсли;
    Возврат СрокИспользования;
    КонецФункции

    // nvk {
    Функция ПолучитьОстСтоимостьНаДату(НОА, ВыбДата, СчИзноса, Сч)
    Перем Ит;
    Перем Результат;
    Перем спСчетов;
    Перем Износ, ПервСтоимость;
    Результат = 0;
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    спСчетов = СоздатьОбъект("СписокЗначений");
    спСчетов.ДобавитьЗначение(СчИзноса);
    спСчетов.ДобавитьЗначение( Сч);
    Ит.ИспользоватьРазделительУчета(Фирма);
    Ит.ИспользоватьСубконто(ВидыСубконто.НеоборотныеАк тивы, НОА, 2); // ОС, НМА
    Ит.ВыполнитьЗапрос(ВыбДата,,спСчетов);
    Ит.ВыбратьСубконто(1);
    Износ = 0;
    ПервСтоимость = 0;
    Пока Ит.ПолучитьСубконто(1) = 1 Цикл
    Если Ит.ПолучитьСчет(,СчИзноса) = 1 Тогда
    Износ = Ит.СНК("С");
    КонецЕсли;
    Если Ит.ПолучитьСчет(,Сч) = 1 Тогда
    ПервСтоимость = Ит.СНД("С");
    КонецЕсли;
    КонецЦикла;
    Результат = Макс(ПервСтоимость - Износ, 0);

    Возврат Результат;
    КонецФункции
    // nvk }


    // ===============================
    // рассчитывает износ по конкретному ОС, НМА, необоротному активу
    // по установленному для него методу
    Процедура РассчитатьИзносПоЭлементу(Элемент,ПервСтоимость,Пе рвКво,ОстСтоимость,СчИзноса,Сч,ПервСтоимостьНУ,Ост СтоимостьНУ,СчИзносаНУ,СчНУ)
    Элемент.ИспользоватьДату(НачМесяца(ДатаДок) - 1,1);
    Если Элемент.МетодРасчетаИзноса.Выбран() = 0 Тогда
    глКомментарий(Строка(Элемент)+": не задан метод расчета износа. Износ не начислен!",0,,"!");
    Возврат;
    КонецЕсли;
    Если ПервКво = 0 Тогда
    Если ОстСтоимость > 0 Тогда
    глКомментарий(Строка(Элемент)+": Первоначальное количество равно 0. Износ не начислен!",0,,"!");
    КонецЕсли;
    Возврат;
    КонецЕсли;
    СуммаИзноса = 0;ИзношеноПолностью = 0;
    ЛиквидационнаяСтоимость = Элемент.ЛиквидационнаяСтоимость * ПервКво;
    //налоговый учет
    СуммаИзносаНУ = 0;ИзношеноПолностьюНУ = 0;

    Если Элемент.МетодРасчетаИзноса = Перечисление.МетодыРасчетаИзноса.ПервыйМесяц Тогда
    // Установим признак "ИзношеноПолностью" если применяется метод "100%"
    //ИначеЕсли Элемент.МетодРасчетаИзноса = Перечисление.МетодыРасчетаИзноса.Налоговый Тогда
    // // Установим признак "ИзношеноПолностью" если применяется "Налоговый" метод
    Иначе
    // Установим признак "ИзношеноПолностью" если для всех остальных методов
    Если (ОстСтоимость < 0) или (ОстСтоимость<=ЛиквидационнаяСтоимость) Тогда
    ИзношеноПолностью = 1;
    КонецЕсли;
    Если (ОстСтоимостьНУ < 0) или (ОстСтоимостьНУ<=ЛиквидационнаяСтоимость) Тогда
    ИзношеноПолностьюНУ = 1;
    КонецЕсли;
    КонецЕсли;

    Если (ИзношеноПолностью = 0) или (ИзношеноПолностьюНУ = 0) Тогда
    //ПрямолинейноеСписание
    Если Элемент.МетодРасчетаИзноса = Перечисление.МетодыРасчетаИзноса.ПрямолинейноеСпис ание Тогда
    Если Элемент.СрокИспользования = 0 Тогда
    глКомментарий(Строка(Элемент)+": не задан срок полезного использования. Износ не начислен!",0,,"!");
    Возврат;
    КонецЕсли;
    // nvk {
    Если ПоОстаточнойСтоимости = 1 Тогда
    ОстНа20110401 = ПолучитьОстСтоимостьНаДату(Элемент, "01.04.2011", СчИзноса, Сч);
    СуммаИзноса = Макс(Окр((ОстНа20110401 - ЛиквидационнаяСтоимость)/Элемент.СрокИспользования,2),0);
    Иначе
    // nvk }

    СуммаИзноса = Макс(Окр((ПервСтоимость - ЛиквидационнаяСтоимость)/Элемент.СрокИспользования,2),0);
    // nvk {
    КонецЕсли;
    // nvk }

  5. Вверх #5
    Цитата Сообщение от nvk Посмотреть сообщение
    В общем случае не должна быть равна (по НОА нал учет может не вестись)
    Реальная проблема в том, что в БУ алгоритм делает расчет по первоначальной стоимости.
    Вместо этого надо по остаточной на 01.04.

    В начислении износа, попробуйте рассчитать остаточную стоимость на 01.04. и использовать ее вместо первоначальной. Что-то вроде следующего получится,
    где ПоОстаточнойСтоимости - новый доп. флаг в документе, если установлен то работать по измененному алгоритму.
    Вопрос спорный. Прямолинейный метод четко говорит начальную стоимость / срок использования. Вопрос: можно ли считать в БУ начальной стоимостью стоимость остаточную на 01.04. (как в НУ приняли). Наверно нельзя - это нигде не оговаривается. И разработчики 1С тоже придерживаются такой политики, наверно же они консультировались с налоговой. Не хочется править так сильно алгоритм, наверняка окажется потом что это не правильно. Да и по самому алгоритму, наверно можно проще сделать (кто захочет): взять сумму амортизации НУ и подставлять ее в проводку БУ, но это наверно тоже не верно.
    Весь глобальный вопрос: сумма амортизации БУ и НУ должна быть равна или нет. Если нет, то стандартный механизм начисления амортизации в 288 релизе можно считать верным.

  6. Вверх #6
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    37
    Сообщений
    470
    Репутация
    56
    Цитата Сообщение от imported_VVV Посмотреть сообщение
    Да и по самому алгоритму, наверно можно проще сделать (кто захочет): взять сумму амортизации НУ и подставлять ее в проводку БУ, но это наверно тоже не верно.
    Да, будет неверно. Не будем забывать про нормы ремонта и модернизации ОС (Для БУ и НУ суммы будут разные)

    Цитата Сообщение от imported_VVV Посмотреть сообщение
    Весь глобальный вопрос: сумма амортизации БУ и НУ должна быть равна или нет.
    Официального разъяснения от налоговой на этот вопрос нет.

  7. Вверх #7
    Постоялец форума
    Пол
    Мужской
    Сообщений
    2,653
    Репутация
    687
    Цитата Сообщение от vitasw Посмотреть сообщение
    Да, будет неверно. Не будем забывать про нормы ремонта и модернизации ОС (Для БУ и НУ суммы будут разные)


    Официального разъяснения от налоговой на этот вопрос нет.
    Если взглянуть одним глазком в конфы по 1С, то там заметно, что весь бухучет становится равным налоговому учету. Правильнее так, налоговый и бухучет слился воедино, теперь есть бухучет с налоговыми отклонениями. Но все "спорные" моменты теперь подогнаны к налоговому кодексу, хотя ПСБУ допускает неиспользование правил налогового законодательства в учете.


Ответить в теме

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения