Одесса: 2°С (вода 8°С)
Киев: 0°С
Львов: -4°С

Тема: Закачка данных из Excel в 1С

Ответить в теме
Показано с 1 по 6 из 6
  1. Вверх #1
    Постоялец форума Аватар для ALMA
    Пол
    Мужской
    Сообщений
    2,347
    Репутация
    656

    По умолчанию Закачка данных из Excel в 1С

    Ребята, помогите!
    Перехожу на 1С "Торговля и склад". Но вот проблема - у меня справочник номенклатуры около 5 тыс., да еще по 5 цен на каждую позицию. Руками набивать просто нереально долго. Поэтому есть вопрос: как закачать из экселя в 1С данные?


  2. Вверх #2
    написать программу которая это сделает? да?

  3. Вверх #3
    Постоялец форума Аватар для ALMA
    Пол
    Мужской
    Сообщений
    2,347
    Репутация
    656
    Цитата Сообщение от Panda Посмотреть сообщение
    написать программу которая это сделает? да?
    Я думала что можно каким-то запросом это выполнить... я ж юзер, поэтому такие вопросы и задаю.

  4. Вверх #4
    Цитата Сообщение от Lana.Aisha Посмотреть сообщение
    Я думала что можно каким-то запросом это выполнить... я ж юзер, поэтому такие вопросы и задаю.
    Из DBF подойдет!
    http://rapidshare.com/files/53570911/ImportDBF.ert.html

  5. Вверх #5
    Посетитель Аватар для Firewoolf
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    32
    Сообщений
    260
    Репутация
    37
    Цитата Сообщение от Lana.Aisha Посмотреть сообщение
    Ребята, помогите!
    Перехожу на 1С "Торговля и склад". Но вот проблема - у меня справочник номенклатуры около 5 тыс., да еще по 5 цен на каждую позицию. Руками набивать просто нереально долго. Поэтому есть вопрос: как закачать из экселя в 1С данные?
    Пишешь обработку которая читает данные из экселевского документа и благополучно их запихуеть в твою новую базу
    Либо через DBF

  6. Вверх #6
    Модератор
    Мистер Одесский Форум
    Аватар для maxx™
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    38
    Сообщений
    23,360
    Репутация
    6089
    Цитата Сообщение от Lana.Aisha Посмотреть сообщение
    Ребята, помогите!
    Перехожу на 1С "Торговля и склад". Но вот проблема - у меня справочник номенклатуры около 5 тыс., да еще по 5 цен на каждую позицию. Руками набивать просто нереально долго. Поэтому есть вопрос: как закачать из экселя в 1С данные?
    Вот тебе пример загрузки в справочник некоторых полей справочника:
    Процедура ЗанрузитьХарактеристики()
    Если ПустоеЗначение(ИмяФайла)=1 Тогда
    Предупреждение("Не задано имя файла!");
    Возврат;
    КонецЕсли;
    Если ФС.СуществуетФайл(ИмяФайла)=0 Тогда
    Предупреждение("Неверно задано имя файла!");
    Возврат;
    КонецЕсли;
    НачатьТранзакцию();
    Попытка
    Excel = СоздатьОбъект("Excel.Application");
    Исключение
    Сообщить("Похоже, Excel на компьютере не установлен. Необходимо выполнить установку/переустановку Excel.","!");
    Возврат;
    КонецПопытки;
    Excel.Workbooks.Open(Сокрлп(ИмяФайла));
    Книга = Excel.ActiveWorkbook;
    Строк = Excel.Cells.CurrentRegion.Rows.Count;
    Тов=СоздатьОбъект("Справочник.ТМЦ");
    Тов.ИспользоватьРодителя(ВыбТМЦ);
    Тов.ИспользоватьДату(ВыбДата);

    Для ТекСтрока=1 по Строк Цикл
    КодВид = Excel.Cells(ТекСтрока, 1).Value;


    // Если ПустаяСтрока(Накл)=1 Тогда
    // Продолжить;
    // КонецЕсли;


    Если Тов.НайтиПоКоду(Строка(КодВид),1)= 0 Тогда
    Сообщить("Не найден товар! "+ КодВид);
    Продолжить;
    КонецЕсли;

    Если КолТУ <> 0 Тогда
    Тов.ТУ = Excel.Cells(ТекСтрока, КолТУ).Value;;
    КонецЕсли;

    Если КолМат <> 0 Тогда
    Тов.Материал = Excel.Cells(ТекСтрока, КолМат).Value;
    КонецЕсли;

    Если КолПр <> 0 Тогда
    Тов.Производитель = Excel.Cells(ТекСтрока, КолПр).Value;
    КонецЕсли;

    Если КолНакл <> 0 Тогда
    Тов.Накл = Excel.Cells(ТекСтрока, КолНакл).Value;
    КонецЕсли;

    Сообщить(Тов.код+" "+Тов.Наименование+" загружено ");

    Тов.Записать();


    КонецЦикла;
    ЗафиксироватьТранзакцию();
    Excel.Visible=1;
    Сообщить(" - Загрузка ЗАВЕРШЕНА !!!");

    КонецПроцедуры


Ответить в теме

Похожие темы

  1. Вопрос по Excel
    от Melafon в разделе Программное обеспечение
    Ответов: 2
    Последнее сообщение: 24.01.2007, 09:55
  2. Проблема с Excel 2003
    от nickmorgan в разделе Программное обеспечение
    Ответов: 3
    Последнее сообщение: 11.12.2006, 12:48
  3. Константы EXCEL
    от Panda в разделе 1С
    Ответов: 3
    Последнее сообщение: 09.05.2006, 18:19
  4. Пример использованимя VBA для Excel
    от Broken Sword в разделе Программирование
    Ответов: 5
    Последнее сообщение: 06.02.2006, 21:17
  5. Excel в *.pdf
    от VIP в разделе Программное обеспечение
    Ответов: 3
    Последнее сообщение: 27.09.2005, 23:52

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения