Одесса: 2°С (вода 8°С)
Киев: 0°С
Львов: -2°С

Тема: Подскажите по 8_2

Ответить в теме
Показано с 1 по 12 из 12
  1. Вверх #1
    Посетитель
    Пол
    Мужской
    Возраст
    44
    Сообщений
    232
    Репутация
    25

    По умолчанию Подскажите по 8_2

    Сразу скажу а не программист, а так продвинутый юзер наверное. Столкнулся с проблемой в конфигурации "Управление торговлей для Украины, редакция 2.3". При заполнении нового контактного лица контрагента не проходит проверка выдает следующую фигню:

    при любых вариантах заполнения.
    в модуле есть такая фигня:

    Процедура ПередЗаписью(Отказ)

    СтруктураОбязательныхПолей = Новый Структура;
    СтруктураОбязательныхПолей.Вставить("Владелец","Ко нтрагент");

    ЗаголовокСообщений = Заголовок;
    Для Каждого КлючЗначение Из СтруктураОбязательныхПолей Цикл
    Значение = ЭтотОбъект[КлючЗначение.Ключ];

    Если НЕ ЗначениеЗаполнено(Значение) Тогда
    СтрокаСообщения = "Не заполнено значение реквизита """ + КлючЗначение.Значение + """!";
    ОбщегоНазначения.СообщитьОбОшибке(СтрокаСообщения, Отказ, ЗаголовокСообщений);
    КонецЕсли;
    КонецЦикла;

    Если НЕ ЗначениеЗаполнено(КонтактноеЛицо) Тогда
    // новое контактное лицо
    НовоеКонтактноеЛицо = Справочники.КонтактныеЛица.СоздатьЭлемент();
    НовоеКонтактноеЛицо.Фамилия = Фамилия;
    НовоеКонтактноеЛицо.Имя = Имя;
    НовоеКонтактноеЛицо.Отчество = Отчество;
    НовоеКонтактноеЛицо.Наименование = Фамилия + " " + Имя + " " + Отчество;
    НовоеКонтактноеЛицо.ДатаРождения = ДатаРождения;
    НовоеКонтактноеЛицо.НапоминатьОДнеРождения = НапоминатьОДнеРождения;
    НовоеКонтактноеЛицо.КоличествоДнейДоНапоминания = КоличествоДнейДоНапоминания;
    НовоеКонтактноеЛицо.Пол = Пол;

    Попытка
    НовоеКонтактноеЛицо.Записать();
    Исключение
    Отказ = Истина;
    Сообщить(ОписаниеОшибки());
    Возврат;
    КонецПопытки;

    КонтактноеЛицо = НовоеКонтактноеЛицо.Ссылка;
    КонецЕсли;

    Наименование = КонтактноеЛицо;

    КонецПроцедуры

    что не так не пойму
    моих мозгов мало

    может оставить только фамилию
    НовоеКонтактноеЛицо.Наименование = Фамилия + " " + Имя + " " + Отчество

    Не бросайте камнями за дилетантские вопросы плиззз
    Изображения
    • Тип файла: jpg 1s.jpg (105.6 Кб, Просмотров: 206)


  2. Вверх #2
    В какой момент возникает ошибка?
    Представленный код в каком модуле?
    Скорее всего надо просто написать Наименование = Фамилия + Имя + Отчество; в процедуре перед записью. А не при записи нового элемента создавать еще один элемент.Последние утверждения основаны на предположениях, так что если ошибся ..

  3. Вверх #3
    Частый гость Аватар для Yana1282
    Пол
    Женский
    Адрес
    Одесса
    Возраст
    35
    Сообщений
    679
    Репутация
    117
    Поставьте 8.1 и не мучайтесь

  4. Вверх #4
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    37
    Сообщений
    470
    Репутация
    56
    Честно говоря сам текст ошибки (Из служебных сообщений) в представленном тексте модуля я не нашел. Может ошибка возникает в другом месте? попробуйте отладчиком найти строку в которой вызывается ошибка...

  5. Вверх #5
    Наименование = Фамилия + Имя + Отчество; в процедуре перед записью.- Это поможет,сам лично проверял,тоже была такая ситуация

  6. Вверх #6
    Новичок
    Пол
    Мужской
    Возраст
    38
    Сообщений
    2
    Репутация
    10
    Цитата Сообщение от Кальмен Посмотреть сообщение
    Наименование = Фамилия + Имя + Отчество; в процедуре перед записью.- Это поможет,сам лично проверял,тоже была такая ситуация
    а если Наименование уже чем либо заполненно заполенно... Ведь затрет. И после каждой записи будет "затирать"...

  7. Вверх #7
    Частый гость Аватар для Yana1282
    Пол
    Женский
    Адрес
    Одесса
    Возраст
    35
    Сообщений
    679
    Репутация
    117
    можно проверить было ли заполнено и с точки зрения предметной области ФИО - не такое уж плохое наименование для контактного лица

  8. Вверх #8
    Посетитель
    Пол
    Мужской
    Возраст
    44
    Сообщений
    232
    Репутация
    25
    Спасибо! Но не помогло, закоментировал строку, но бестолку, один черт выдает эту ошибку. Самое интересное что эта конфигурация до обновления в режиме совместимости с 8.1 рботает нормально, в модуле ничего не изменилось.

  9. Вверх #9
    Цитата Сообщение от tungus Посмотреть сообщение
    Спасибо! Но не помогло, закоментировал строку, но бестолку, один черт выдает эту ошибку. Самое интересное что эта конфигурация до обновления в режиме совместимости с 8.1 рботает нормально, в модуле ничего не изменилось.
    выложи конфигурацию. Посмотрим разберемся.

  10. Вверх #10
    Новичок Аватар для teacher
    Пол
    Мужской
    Адрес
    Одесса
    Сообщений
    60
    Репутация
    25
    Данная проверка производится на уровне метаданных. Чтобы ее убрать - заходим в Конфигуратор выбираем свойства справочника КонтактныеЛицаКонтрагентов переходим во вкладку Данные и нажимаем кнопку стандартные реквизиты. В открывшемся окне вымираем реквизит наименование и открываем его свойства. В свойстве проверка заполнения выбираем - не проверять. Так сделал и все работает. Но как это скажется в дальнейшем на работоспособность конфигурации не знаю.

  11. Вверх #11
    Посетитель Аватар для Avicenna
    Пол
    Мужской
    Возраст
    17
    Сообщений
    174
    Репутация
    67
    от молодец! Вместо того, чтобы отработать процедуру заполнения наименования, убираем контроль заполнения! Выше ведь написали, чё ПередЗаписью в модуле объекта слепить... тока про разделители меж лексемами забыли.

    зы можно еще, кстати, освоить обработчик ОбработкаПроверкиЗаполнения

  12. Вверх #12
    Новичок Аватар для teacher
    Пол
    Мужской
    Адрес
    Одесса
    Сообщений
    60
    Репутация
    25
    Проверка заполнения стандартных реквизитов появилась 8.2 в 8.1 ее не было. Она происходит еще до выполнения функции ПередЗаписью. Получается, что данный реквизит заполняется в этой функции, а во время проверки реквизит пуст. Если посмотреть модуль справочника контактные лиц, то там этот реквизит заполняется в функциях, которые вызываются при вводе ФИО, поэтому там этой ошибки не возникает.


Ответить в теме

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения