Тема: Сложные бухгалтерские расчтеы

Ответить в теме
Показано с 1 по 15 из 15
  1. Вверх #1
    Постоялец форума
    Пол
    Мужской
    Адрес
    Одесса
    Сообщений
    1,029
    Репутация
    249

    По умолчанию Сложные бухгалтерские расчтеы

    Кто-нибудь может привести пример сложной формулы, по которой в бухгалтерском деле что-л. расчитывается?


  2. Вверх #2
    Модератор Аватар для Mulder_1
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    38
    Сообщений
    772
    Репутация
    51
    Сложность штука относительная ...
    например если брать расчет з/п (нормального человека с начислениями во все фонды по шкале и удержанием подоходного) , тогда получится примерно так :
    есть оклад (база налогообдложения) , в из него идут вычеты в фонды : пенсионный(2% - берется по шкале : до 150 - 1%, после 150 - 2% ), безработица(0,5%) , соц. страх (1% - берется по шкале : до 453 - 0,5% после 453 - 1%),
    потом из остатка налог на доходы физ лиц (13%), + прочие начисления( премии, выслуга лет и т.д. они будут являтся базой для отчислений в фонды но не для НДФЛ) - прочие удержания (штрафы , тел. переговоры)
    получается чистая сумма к выдаче...
    Кратк. - сестр. тал. !

  3. Вверх #3
    Постоялец форума
    Пол
    Мужской
    Адрес
    Одесса
    Сообщений
    1,029
    Репутация
    249
    Mulder_1, конечно! А математически можно записать как-то?

  4. Вверх #4
    Модератор Аватар для Mulder_1
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    38
    Сообщений
    772
    Репутация
    51
    Оклад : 100 000 грн (шоб удобнее считать)
    пенсионный : 1 000(расчитывается по пределам)
    безработица : 500
    соц. страх : 1 000 (расчитывается по пределам)
    итого удержания : 2 500
    остаток: 97 500
    НДФЛ : 12 675

    Итого на руки : 84 825

    это фактически одна сторонва медали ... т.е. "условно" на что попал сотрудник (в мухгалтерии это кореспонденция 661 и 62.Х счетов , НДФЛ ляжет на 6411)
    с другой стороны идут отчисления
    Кратк. - сестр. тал. !

  5. Вверх #5
    Постоялец форума
    Пол
    Мужской
    Адрес
    Одесса
    Сообщений
    1,029
    Репутация
    249
    т.е. тут используются операции умножения и вычитания, а посложнее ничего нет? ну там логарифмы и т.п.?

  6. Вверх #6
    Модератор Аватар для Mulder_1
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    38
    Сообщений
    772
    Репутация
    51
    Цитата Сообщение от Broken Sword
    т.е. тут используются операции умножения и вычитания, а посложнее ничего нет? ну там логарифмы и т.п.?
    ну логорифмы в бух учете что-то не припомню шоб брались ...
    в основном сложение/вычитание/умножение/деление
    Кратк. - сестр. тал. !

  7. Вверх #7
    Модератор Аватар для Mulder_1
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    38
    Сообщений
    772
    Репутация
    51
    Если не секрет , а почему такой вопрос возник ?
    Кратк. - сестр. тал. !

  8. Вверх #8
    Постоялец форума
    Пол
    Мужской
    Адрес
    Одесса
    Сообщений
    1,029
    Репутация
    249
    Mulder_1, скажем так - выполняя бухгалтерские вычисления мне нужно максимально загрузить проц. Можешь привести хотя бы пример функции, пусть не использующую сложных операций, но которая выполняется долгое время (секунды) на современных машинах?

  9. Вверх #9
    Модератор Аватар для Mulder_1
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    38
    Сообщений
    772
    Репутация
    51
    а-а-а !!
    т.е. тебе что-то надо типа замера производительности ?

    можно так:

    Процедура ЗагрузкаПроца()
    нач_вр=_GetPerformanceCounter();

    для ии=1 по 1000000 цикл
    для кк=1 по 1000000 цикл
    Сообщить("цкуес64кп6ц5у4пк65уц4пк564цк6п54цсу6пк54 ");
    Состояние("вапвпрвырм25564мр46е5р4мк65ре4у3к4реу56 4");
    конецЦикла;
    конецЦикла;

    кон_вр=_GetPerformanceCounter();

    Прудпреждение("Общее время выполнения :"+Строка(нач_вр-кон_вр));//результат будет в 1000-чных долях секунды

    КонецПроцедуры
    Кратк. - сестр. тал. !

  10. Вверх #10
    Постоялец форума
    Пол
    Мужской
    Адрес
    Одесса
    Сообщений
    1,029
    Репутация
    249
    нужна загрузка именно бухгалтерскими расчетами, причем реальными

  11. Вверх #11
    Модератор Аватар для Mulder_1
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    38
    Сообщений
    772
    Репутация
    51
    если есть какая-то бухгалтерская база под рукой , тогда сделай карточку счета за весь период по всех счетам.... и то , большая чать времени будет уходить на чтение из базы...

    а так , если нет базы - тогда сложновато что-то реально проверить ....
    Кратк. - сестр. тал. !

  12. Вверх #12
    А смысл загрузки проца такими расчетами?

  13. Вверх #13
    Посетитель Аватар для Diver
    Пол
    Мужской
    Адрес
    Odessa
    Сообщений
    231
    Репутация
    15
    Broken Sword, вы немного не в ту степь зашли!

    Обратимся к истокам! Что такое бухгалтерия!?
    Это свод отчётов о деятельности предприятия перед различными государственными органами!
    Какие в ... логарифмы, корни или интеграля с производными...

    Сложность бухрасчётов состоит не в математических операциях а в количестве необходимых нюансов, которые являются условиями расчётов!

    Вам тога в прогнозы нужно идти - там уже и ряды и т.д....

  14. Вверх #14
    ну, я не был бы столь категоричным... как минимум один из методов начисления амортизации, если я не ошибаюсь, то "Уменьшение остатка", использует в своей формуле корень N-ой степени. Да вы и сами можете посмотреть в документе "НачислениеИзноса" в типовой бух, комплексной или ПУБ Украины.
    aka Bucђ

  15. Вверх #15
    Посетитель Аватар для Diver
    Пол
    Мужской
    Адрес
    Odessa
    Сообщений
    231
    Репутация
    15
    фин, твоя правда

    // ===============================
    // возвращает корень от числа Основание со степенью Степень
    Функция Корень(Основание,Степень)
    Если Степень = 1 Тогда
    Возврат(Основание);
    КонецЕсли;
    Факториал = 1; Степень_ = 1; Сум = 0;
    СтепеньЕ = 1/Степень*Лог(Основание);
    Для ии = 1 по 28 Цикл
    Факториал = Факториал * ии;
    Степень_ = Степень_ * СтепеньЕ;
    Сум = Сум + Степень_/Факториал
    КонецЦикла;
    Возврат(1+Сум);
    КонецФункции


Ответить в теме

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения