Одесса: 5°С (вода 8°С)
Киев: 1°С
Львов: 3°С

Тема: подскажите как решить.

Ответить в теме
Страница 1 из 2 1 2 ПоследняяПоследняя
Показано с 1 по 20 из 32
  1. Вверх #1
    Не покидает форум Аватар для rakar
    Пол
    Мужской
    Сообщений
    7,964
    Репутация
    1101

    По умолчанию подскажите как решить.

    хочу сделать в справочнике товаров колонку для отображения количества реальных остатков по товару. подскажите плиз как это реализовать.
    «эксперимент — критерий истины»


  2. Вверх #2
    Посетитель
    Пол
    Мужской
    Адрес
    пгт.Великодолинское
    Сообщений
    173
    Репутация
    21
    Записей в дневнике
    1
    Уточните пожалуйста какая платформа, какая конфигурация и какой релиз
    ryakovlev.blogspot.com

  3. Вверх #3
    Не покидает форум Аватар для rakar
    Пол
    Мужской
    Сообщений
    7,964
    Репутация
    1101
    1С Предприятие 7.7 , SQL, 7.70.015

    можно на этом простом примере (мини-склад) применить реализацию данной задачи
    Последний раз редактировалось rakar; 25.05.2009 в 14:13.
    «эксперимент — критерий истины»

  4. Вверх #4
    Функция ОстатокНаСкладе()
    Возврат Регистр.ОстаткиТоваров.СводныйОстаток(ТекущийЭлеме нт),,"Количество");
    КонецФункции

    Добавляешь колонку табличную часть формы списка и прописываешь туда эту функцию. Т.к. у тебя SQL можеш перевести в прямой запрос будет гораздо быстрее!

  5. Вверх #5
    Не покидает форум Аватар для rakar
    Пол
    Мужской
    Сообщений
    7,964
    Репутация
    1101
    так надо было сделать? в колонку табличной части формы списка прописал туда эту функцию ОстатокНаСкладе().

    Функция ОстатокНаСкладе()
    Возврат Регистр.ОстаткиТоваров.СводныйОстаток(ТекущийЭлеме нт),,"Количество");
    КонецФункции;

    Процедура Печать()
    Спр = СоздатьОбъект("Справочник.Товары");
    Спр.ИспользоватьДату(ИспользоватьДату());
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Печать");
    Таб.ВывестиСекцию("Шапка");
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
    Если Спр.ЭтоГруппа() = 1 Тогда
    Таб.ВывестиСекцию("Группа");
    Иначе
    Таб.ВывестиСекцию("Строка");
    КонецЕсли;
    КонецЦикла;
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Печать Товары","");
    КонецПроцедуры
    Возврат Регистр.ОстаткиТоваров.СводныйОстаток(ТекущийЭлеме нт<<?>>),,"Количество");
    {Справочник.Товары.ФормаСписка.ФормаСписка.Модуль( 7)}: Переменная не определена (ТекущийЭлемент)
    Возврат Регистр.ОстаткиТоваров.СводныйОстаток(ТекущийЭлеме нт)<<?>>,,"Количество");
    {Справочник.Товары.ФормаСписка.ФормаСписка.Модуль( 7)}: Неопознанный оператор
    <<?>>Процедура Печать()
    {Справочник.Товары.ФормаСписка.ФормаСписка.Модуль( 10)}: Определения процедур и функций должны размещаться перед операторами основной программы
    «эксперимент — критерий истины»

  6. Вверх #6
    Новичок
    Пол
    Мужской
    Адрес
    Киев
    Сообщений
    70
    Репутация
    11
    Возврат Регистр.ОстаткиТоваров.СводныйОстаток(ТекущийЭлеме нт()),,"Количество");

    и сделай синтаксический контроль

  7. Вверх #7
    Не покидает форум Аватар для rakar
    Пол
    Мужской
    Сообщений
    7,964
    Репутация
    1101
    все равно не работает
    «эксперимент — критерий истины»

  8. Вверх #8
    Открой синтакс-помошник и посмотри СводныйОстаток(). Подставь правильно свои ресурсы и измерения и будет тебе счастье.

  9. Вверх #9
    Новичок
    Пол
    Мужской
    Адрес
    Киев
    Сообщений
    70
    Репутация
    11
    какие ошибки пишет на этот раз?

  10. Вверх #10
    Не покидает форум Аватар для rakar
    Пол
    Мужской
    Сообщений
    7,964
    Репутация
    1101
    ошибок не выдает но и не работает как нужно
    «эксперимент — критерий истины»

  11. Вверх #11
    Новичок
    Пол
    Мужской
    Адрес
    Киев
    Сообщений
    70
    Репутация
    11
    а как работает? опиши что выдает и что тебя не устраивает.
    Последний раз редактировалось Leon(Grisha); 26.05.2009 в 11:26. Причина: кое-что забыл

  12. Вверх #12
    Не покидает форум Аватар для rakar
    Пол
    Мужской
    Сообщений
    7,964
    Репутация
    1101
    ....
    КонецПроцедуры


    //}}ПРОЦЕДУРА_ПЕЧАТИ

    Функция ОстатокНаСкладе()
    Возврат Регистр.ОстаткиТоваров.СводныйОстаток(ТекущийЭлеме нт(),"Количество");
    КонецФункции;
    в справочнике же, в колонке кол-во, после приходывания товара количество не меняется.

    модуль приходки:
    Процедура ОбработкаПроведения()

    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    регистр.ОстаткиТоваров.Товар=Товар;
    регистр.ОстаткиТоваров.Количество=Количество;
    регистр.ОстаткиТоваров.ДвижениеПриходВыполнить();
    КонецЦикла;
    КонецПроцедуры
    «эксперимент — критерий истины»

  13. Вверх #13
    Постоялец форума Аватар для Aniana
    Пол
    Женский
    Сообщений
    1,263
    Репутация
    174
    А ты функцию на форму вставил?

  14. Вверх #14
    Не покидает форум Аватар для rakar
    Пол
    Мужской
    Сообщений
    7,964
    Репутация
    1101
    Цитата Сообщение от Aniana Посмотреть сообщение
    А ты функцию на форму вставил?
    вы про это?
    Изображения
    «эксперимент — критерий истины»

  15. Вверх #15
    Постоялец форума Аватар для Aniana
    Пол
    Женский
    Сообщений
    1,263
    Репутация
    174
    Да про это. а "Количество" это у вас реквизит?

  16. Вверх #16
    Живёт на форуме Аватар для Alochka
    Пол
    Женский
    Адрес
    Одесса пос. Котовского
    Возраст
    42
    Сообщений
    3,085
    Репутация
    1310
    А что теперь пишет?

  17. Вверх #17
    Мда!!! быстрее было бы уже в книжке примерчик найти

  18. Вверх #18
    Не покидает форум Аватар для rakar
    Пол
    Мужской
    Сообщений
    7,964
    Репутация
    1101
    Цитата Сообщение от Aniana Посмотреть сообщение
    Да про это. а "Количество" это у вас реквизит?
    да как реквезит.
    «эксперимент — критерий истины»

  19. Вверх #19
    Постоялец форума Аватар для Aniana
    Пол
    Женский
    Сообщений
    1,263
    Репутация
    174
    А надо не как реквизит. Добавь просто тект на табличную часть. И в этой колонке в формули пропиши функцию.

  20. Вверх #20
    Не покидает форум Аватар для rakar
    Пол
    Мужской
    Сообщений
    7,964
    Репутация
    1101
    Цитата Сообщение от Aniana Посмотреть сообщение
    А надо не как реквизит. Добавь просто тект на табличную часть. И в этой колонке в формули пропиши функцию.
    спасибо большее, все заработало.
    «эксперимент — критерий истины»


Ответить в теме
Страница 1 из 2 1 2 ПоследняяПоследняя

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения