Одесса: 5°С (вода 9°С)
Киев: -1°С
Львов: 4°С

Тема: Как перебрать строки документа 8.2 из 7.7

Ответить в теме
Показано с 1 по 7 из 7
  1. Вверх #1

    По умолчанию Как перебрать строки документа 8.2 из 7.7

    из 7.7 подключаюсь к базе 8.2 через V82.Application.
    Документ получил. Как перебрать строки документа?
    "Для каждого" 7.7 не понимает.
    А "ВыбратьСтроки" не понимает 8.2.
    По индексу тоже не могу обратиться к строке.


  2. Вверх #2
    Модератор Аватар для Mulder_1
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    38
    Сообщений
    772
    Репутация
    51
    а как пробуешь по индексу обращаться ??

    поидее как то так :

    Код:
    квоСтрок82 = ДокументОбъектОЛЕ82.ИмятабличнойЧасти.Количество();
    Для ии = 1 По квоСтрок82 Цикл
         _значениеВСтроке = ДокументОбъектОЛЕ82.ИмятабличнойЧасти[ии].ИмяРеквизита.ПолеРеквизитаИмеющееПростойТип
    КонецЦикла;
    вообщем желательно бы твой код глянуть ...
    Кратк. - сестр. тал. !

  3. Вверх #3
    Примерно следующее написал:

    v82 = СоздатьОбъект("V82.Application");
    ...
    ДокументыПеремещ = v82.Документы.ПеремещениеТоваров;

    Выборка = ДокументыПеремещ.Выбрать(НачДата, КонДата);

    Пока Выборка.Следующий()<>0 Цикл


    ДокОприх=СоздатьОбъект("Документ.ОприходованиеИзли шков");

    ДокОприх.Новый();

    глЗаполнитьШапку(ДокОприх);

    //тут методом научного тыка подбираю варианты

    //СтаршийИндекс = Выборка.Товары.Количество() - 1;
    //
    //Для Сч = 0 по СтаршийИндекс Цикл
    //
    // СтрокаДок= Выборка.Товары[Сч]; //ОШИБКА
    //
    //КонецЦикла;


    //ВыборкаСтрок=Выборка.Товары.ВыбратьСтроки();//ОШИБКА


    //ТаблДок=СоздатьОбъект("ТаблицаЗначений");

    //ТаблДок= Выборка.Товары.Выгрузить();

    //ТаблДок.ВыбратьСтроки(); //ОШИБКА

    КонецЦикла;


    v82=0;

  4. Вверх #4
    Новичок
    Пол
    Мужской
    Адрес
    Одесса
    Сообщений
    22
    Репутация
    13
    Здравствуйте.
    Не проще решить проблему переноса документов через конвертацию?

  5. Вверх #5
    Думаю, стоит попробовать:


    ТаблДок=СоздатьОбъект("ТаблицаЗначений");

    ТаблДок= Выборка.Товары.Выгрузить();

    Пока ТаблДок.ПолучитьСтроку() = 1 Цикл

    КонецЦикла;

  6. Вверх #6
    Нашел способ:

    СтаршийИндекс = Выборка.Товары.Количество() - 1;

    Для Сч = 0 по СтаршийИндекс Цикл

    СтрокаДок= Выборка.Товары.Получить(Сч);

    КодТМЦ=СтрокаДок.Номенклатура.Код;

    Сообщить("КодТМЦ= "+КодТМЦ);

    КонецЦикла;


    Всем спасибо за участие.

  7. Вверх #7
    Постоялец форума Аватар для yarosha
    Пол
    Мужской
    Сообщений
    1,442
    Репутация
    532
    Записей в дневнике
    1

    По умолчанию Месье знает толк в извращениях

    Да, и еще. Незадача.
    Надобно из семерки пометить на удаление в восьмерке. Пропустил при перегрузке. Конвертация, как всегда. Не обратил внимания. Но (sic!), при этом сделал другие вещи. О! Как!

    А прозявал (как всегда) - элементарные вещи. Такой код получился (ну, поправляться ннннадо):
    77:
    Процедура Сформировать()Перем Путь, Файл;
    Т=СоздатьОбъект("Текст");
    Спр = СоздатьОбъект("Справочник.Контрагенты");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
    Если Спр.ПометкаУдаления()=1 Тогда
    Т.ДобавитьСтроку(Прав("000000000"+СокрЛП(Спр.Код), 9));
    КонецЕсли;
    КонецЦикла;
    РасположениеФайла(Путь,Файл);
    Т.Записать(Путь+"Коды.txt");
    КонецПроцедуры

    82:

    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Текст = Новый ТекстовыйДокумент;
    Текст.Прочитать(СтрЗаменить(ЭтотОбъект.Используемо еИмяФайла,"Коды.epf","")+"Коды.txt");
    Для НомерСтроки = 1 По Текст.КоличествоСтрок() Цикл
    Стр = Текст.ПолучитьСтроку(НомерСтроки);
    Контрагент = Справочники.Контрагенты.НайтиПоКоду(Стр);
    Если Не Контрагент = Справочники.Контрагенты.ПустаяСсылка() Тогда
    Контрагент = Контрагент.ПолучитьОбъект();
    Контрагент.УстановитьПометкуУдаления(Истина);
    Сообщить(Стр);
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    Последний раз редактировалось Mulder_1; 02.08.2012 в 16:01.
    Мао Цзэдун - Большой Шалун!
    Just fof Lulz. Ибо Ваистену!!! О! Как!


Ответить в теме

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения