Одесса: 5°С (вода 8°С)
Киев: 0°С
Львов: 1°С

Тема: Черно-белая печать в 1С 8. В чем прикол?

Ответить в теме
Показано с 1 по 15 из 15
  1. Вверх #1
    Частый гость Аватар для anom
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    37
    Сообщений
    618
    Репутация
    80

    Exclamation Черно-белая печать в 1С 8. В чем прикол?

    Доброго времени суток!

    Есть внешняя форма для печати сч-фактуры (платформа 1С 8.2 Бухгалтерия). Проблема с запоминанием печати в цвете/чб.
    Перед пуском на печать изменены параметры печати ( отключена черно-белая печать, есть такая галочка). При новой печати другой сч-фактуры параметры не запоминаются и изменять приходилось вручную снова и снова.
    Как решить эту проблемку с запоминанием параметров печати? Печатать нужно обязательно в цвете.
    Насколько читал форумы - такая проблема у многих


  2. Вверх #2
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    37
    Сообщений
    470
    Репутация
    56
    Программно устанавливаете, программно запоминаете

  3. Вверх #3
    Частый гость Аватар для anom
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    37
    Сообщений
    618
    Репутация
    80
    Не совсем понятно. Можете прояснить?

  4. Вверх #4
    Постоялец форума Аватар для yarosha
    Пол
    Мужской
    Сообщений
    1,442
    Репутация
    532
    Записей в дневнике
    1
    На самом деле - печать - это интересная ситуация.
    Попробуйте программно добраться до настроек печатного устройства - тогда станет все понятно (например из вижал си или из биздела ака делфи).
    Что касается 1С - либо лепим насильно пользователю настройки, либо лепим имеющиеся.
    Мао Цзэдун - Большой Шалун!
    Just fof Lulz. Ибо Ваистену!!! О! Как!

  5. Вверх #5
    Живёт на форуме Аватар для senbernar
    Пол
    Мужской
    Адрес
    Одеса, Ізмаїл
    Возраст
    35
    Сообщений
    3,904
    Репутация
    2735
    Записей в дневнике
    17
    если можете, сбросьте в ЛС внешнюю форму, тогда можно будет поюзать и разобраться, в чем дело.

  6. Вверх #6
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    37
    Сообщений
    470
    Репутация
    56
    Есть общая форма "ФормаПечати" в ней ПриОткрытии(), а там:
    ЭлементыФормы.ПолеДокумента.ОтображатьЗаголовки = Ложь;
    ЭлементыФормы.ПолеДокумента.ОтображатьСетку = Ложь;
    ЭлементыФормы.ПолеДокумента.Защита = Ложь;
    ЭлементыФормы.ПолеДокумента.ТолькоПросмотр = Истина;
    ЭлементыФормы.ПолеДокумента.ИмяПараметровПечати = ПечатныйДокумент.ИмяПараметровПечати;
    ЭлементыФормы.ПолеДокумента.ЧерноБелыйПросмотр = Ложь;
    ЭлементыФормы.ПолеДокумента.ЧерноБелаяПечать = Истина;
    ЭлементыФормы.ПолеДокумента.ПовторятьПриПечатиСтро ки = ПечатныйДокумент.ПовторятьПриПечатиСтроки;

    Вот это :
    ЭлементыФормы.ПолеДокумента.ЧерноБелаяПечать = Истина;
    можно запоминать и восстанавливать программно

  7. Вверх #7
    Постоялец форума Аватар для yarosha
    Пол
    Мужской
    Сообщений
    1,442
    Репутация
    532
    Записей в дневнике
    1
    Цитата Сообщение от vitasw Посмотреть сообщение
    Есть общая форма "ФормаПечати" в ней ПриОткрытии(), а там:
    ЭлементыФормы.ПолеДокумента.ОтображатьЗаголовки = Ложь;
    ЭлементыФормы.ПолеДокумента.ОтображатьСетку = Ложь;
    ЭлементыФормы.ПолеДокумента.Защита = Ложь;
    ЭлементыФормы.ПолеДокумента.ТолькоПросмотр = Истина;
    ЭлементыФормы.ПолеДокумента.ИмяПараметровПечати = ПечатныйДокумент.ИмяПараметровПечати;
    ЭлементыФормы.ПолеДокумента.ЧерноБелыйПросмотр = Ложь;
    ЭлементыФормы.ПолеДокумента.ЧерноБелаяПечать = Истина;
    ЭлементыФормы.ПолеДокумента.ПовторятьПриПечатиСтро ки = ПечатныйДокумент.ПовторятьПриПечатиСтроки;

    Вот это :
    ЭлементыФормы.ПолеДокумента.ЧерноБелаяПечать = Истина;
    можно запоминать и восстанавливать программно
    Многа букоф.
    Вообще есть Меню-Фэйл-итд
    В любой проге есть такая стезя
    А тупо тыкать настройки под нос пользователя - весчь неблагодатная
    Мао Цзэдун - Большой Шалун!
    Just fof Lulz. Ибо Ваистену!!! О! Как!

  8. Вверх #8
    Частый гость Аватар для anom
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    37
    Сообщений
    618
    Репутация
    80
    Вопрос решен с помощью senbernar (детальнейшее описание действий) и vitasw (путь решения проблемы), за что огромное им спасибо!
    Тему закрываем.

  9. Вверх #9
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    37
    Сообщений
    470
    Репутация
    56
    Цитата Сообщение от yarosha Посмотреть сообщение
    Многа букоф.
    не читай

  10. Вверх #10
    Модератор Аватар для Mulder_1
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    38
    Сообщений
    772
    Репутация
    51
    Цитата Сообщение от vitasw Посмотреть сообщение
    не читай
    Как бы это дико не звучало, но я согласен с ярошей ...
    Я тоже не сторонник жесткой привязки настроек печати .. Действительно может "боком" вылезти ... Проблема (возможно) и решена, но это не самое удачное ее решение (имхо)
    Кратк. - сестр. тал. !

  11. Вверх #11
    Живёт на форуме Аватар для senbernar
    Пол
    Мужской
    Адрес
    Одеса, Ізмаїл
    Возраст
    35
    Сообщений
    3,904
    Репутация
    2735
    Записей в дневнике
    17
    Главное, то человек нашел решение, и на данный момент его это решение удовлетворило.
    А если возникнут новые проблемы, тогда и будем их решать, по мере поступления

  12. Вверх #12
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    37
    Сообщений
    470
    Репутация
    56
    Цитата Сообщение от Mulder_1 Посмотреть сообщение
    Как бы это дико не звучало, но я согласен с ярошей ...
    Я тоже не сторонник жесткой привязки настроек печати .. Действительно может "боком" вылезти ... Проблема (возможно) и решена, но это не самое удачное ее решение (имхо)
    Насколько я понял, проблема в том, что определенную форму нужно выводить именно в цвете, тогда как в типовой жестко определяется черно-белое (так реализовано в типовой). Не вижу никакой проблемы, чтобы в зависимости от параметров печати устанавливать/снимать этот флаг.

  13. Вверх #13
    Модератор Аватар для Mulder_1
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    38
    Сообщений
    772
    Репутация
    51
    Вроде нет там такого ...
    Вот как реализована печать в типовой бухии

    Код:
    // Выводит на печать подготовленный макет 
    //
    // Параметры:
    //  ПечДокумент            - ТабличыйДокумент, макет на печать,
    //  КоличествоЭкземпляров  - Число, количество экземпляров на печать,
    //  НаПринтер              - Булево, Если истина, то выводим сразу на принтер.
    //  Заголовок              - Заголовок окна табличного документа
    //  НепосредственнаяПечать - используется только для режи
    Процедура НапечататьДокумент(ПечДокумент, КоличествоЭкземпляров = 1, НаПринтер = Ложь, Заголовок = "", НепосредственнаяПечать = Ложь, Ссылка = Неопределено, ИмяМакета = "") Экспорт
    	Если ПечДокумент = Неопределено тогда
    		Возврат;
    	КонецЕсли;
    
    	// Получить необходимое количество копий
    	Если КоличествоЭкземпляров > 0 Тогда
    		ПечДокумент.КоличествоЭкземпляров = КоличествоЭкземпляров;
    	КонецЕсли;
    
    	Если НЕ ПечДокумент.АвтоМасштаб
    	   И НЕ ЗначениеЗаполнено(ПечДокумент.ИмяПринтера) Тогда
    		ПечДокумент.АвтоМасштаб = Истина;
    	КонецЕсли;
    
    	Если НаПринтер Тогда
    
    		ПечДокумент.Напечатать(НепосредственнаяПечать = Истина);
    
    	Иначе
    
    		// Отобразить печатный документ на экране
    		//ФормаПечати = ПолучитьОбщуюФорму("ФормаПечати",, Новый УникальныйИдентификатор);
    		ФормаПечати = ПолучитьОбщуюФорму("ФормаПечати",, Заголовок + ИмяМакета + Ссылка);
    		ФормаПечати.Документ = Ссылка;
    		ФормаПечати.Заголовок = Заголовок;
    		ФормаПечати.ИмяМакета = ИмяМакета;
    		ФормаПечати.ПечатныйДокумент = ПечДокумент;
    		ФормаПечати.Открыть();
    
    	КонецЕсли;
    
    КонецПроцедуры // НапечататьДокумент()
    По идее подобные настройки хранятся в настройках "сеанса" пользователя... (подозреваю что работают в терминалах, хотя без разницы)
    а значит копать нужно в сторону настройки системы (винды)
    да и вообще любое изменение в бухии НАСТОЯТЕЛЬНО не рекомендовано (можно конечно выкрутиться, но это вроде не тот случай)
    Последний раз редактировалось Mulder_1; 05.10.2011 в 19:37.
    Кратк. - сестр. тал. !

  14. Вверх #14
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    37
    Сообщений
    470
    Репутация
    56
    Цитата Сообщение от Mulder_1 Посмотреть сообщение
    Вроде нет там такого ...
    Вот как реализована печать в типовой бухии

    Код:
    	Если НаПринтер Тогда
    
    		ПечДокумент.Напечатать(НепосредственнаяПечать = Истина);
    
    	Иначе
    
    		// Отобразить печатный документ на экране
    		//ФормаПечати = ПолучитьОбщуюФорму("ФормаПечати",, Новый УникальныйИдентификатор);
    		ФормаПечати = ПолучитьОбщуюФорму("ФормаПечати",, Заголовок + ИмяМакета + Ссылка);
    		ФормаПечати.Документ = Ссылка;
    		ФормаПечати.Заголовок = Заголовок;
    		ФормаПечати.ИмяМакета = ИмяМакета;
    		ФормаПечати.ПечатныйДокумент = ПечДокумент;
    		ФормаПечати.Открыть();
    
    	КонецЕсли;
    
    КонецПроцедуры // НапечататьДокумент()
    После слова "иначе" открывается общая форма, где в "ПриОткрытии()", собственно, и есть код, который я указал выше
    Последний раз редактировалось vitasw; 05.10.2011 в 20:12.

  15. Вверх #15
    Постоялец форума Аватар для yarosha
    Пол
    Мужской
    Сообщений
    1,442
    Репутация
    532
    Записей в дневнике
    1
    Стоит бросить один камет - и тут начинается.
    Впрочем, это даже к лучшему.
    Может просветление в мозгах начнется (у меня и так наступило).
    У меня, например, детальный разбор телодвижений привел меня во второй институт.
    Так что, теперь йя типа "неполный дохтор философии".
    По западной классификации.
    О! Как!
    Мао Цзэдун - Большой Шалун!
    Just fof Lulz. Ибо Ваистену!!! О! Как!


Ответить в теме

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения