Тема: Как понизить php 5.3 на 5.2?На Linux Gentoo VDS

Ответить в теме
Страница 1 из 2 1 2 ПоследняяПоследняя
Показано с 1 по 20 из 29
  1. Вверх #1
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    30
    Сообщений
    176
    Репутация
    21

    По умолчанию Как понизить php 5.3 на 5.2?На Linux Gentoo VDS

    Я купил себе VDS, но обширных знаний в его работе, да и в Linux Gentoo ещё не имею..
    в общим мне потребовалось закинуть на него свой сайт, но написан он на старой версии php и мне её нужно сейчас понизить.. как это можно сделать? и что для этого нужно.. Заранее спасибо))
    ..зачем мы живём.....?и я для чего...


  2. Вверх #2
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    30
    Сообщений
    176
    Репутация
    21
    Крикну.., а в ответ тишина...(с) ))
    ..зачем мы живём.....?и я для чего...

  3. Вверх #3
    Частый гость Аватар для wladwww
    Пол
    Мужской
    Адрес
    Одесса
    Сообщений
    522
    Репутация
    36
    Я так понял 5.3 у тебя на линуксе стоит? Так удалить её и поставить заново старую версию никак?

  4. Вверх #4
    Частый гость Аватар для CrazySquirrel
    Пол
    Мужской
    Возраст
    30
    Сообщений
    900
    Репутация
    95
    Простите, а зачем? Может лучше менять сайт и двигаться вперёд, чем ставить старый PHP и двигаться назад. Различия между 5.2 и 5.3 не такие большие..

    p.s. Слава Б-гу что у вас не на PHP 4 сайт.
    Еврейский SQL сервер отвечает запросом на запрос.

  5. Вверх #5
    Постоялец форума Аватар для Lord of rings
    Пол
    Мужской
    Адрес
    Одесса, типа украина...
    Сообщений
    2,509
    Репутация
    148
    как я помню - в апаче выбирается, какой модуль PHP грузить..... покури httpd.conf
    поищи там строчку типа
    LoadModule php4_module d:/php/php4apache.dll

    в Линуксе соответственно путь будет другой, и модуль иметь расширение .so
    LoadModule php4_module libexec/apache/libphp4.so - например так

    можно иметь несколько версий PHP, а при старте демона httpd грузить соответствующий модуль, а остальные комментировать.
    можно настроить загрузку разных модулей для разных сайтов.... даже если сайт работает с php4 - то не есть проблема...
    Последний раз редактировалось Lord of rings; 27.09.2011 в 11:56.
    Per rectum ad astrum!

  6. Вверх #6
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    30
    Сообщений
    176
    Репутация
    21
    Цитата Сообщение от wladwww Посмотреть сообщение
    Я так понял 5.3 у тебя на линуксе стоит? Так удалить её и поставить заново старую версию никак?
    На VDS на котором Linux Gentoo..

    а в линуксе тем более генту я не силён.., может скажете, как это сделать через SSH..?


    Цитата Сообщение от Lord of rings Посмотреть сообщение
    как я помню - в апаче выбирается, какой модуль PHP грузить..... покури httpd.conf
    можно иметь несколько версий PHP, а при старте демона httpd грузить соответствующий модуль, а остальные комментировать.
    можно настроить загрузку разных модулей для разных сайтов.... даже если сайт работает с php4 - то не есть проблема...
    А как удалить 5.3 через консоль.. и установить через неё же 5.2?



    Цитата Сообщение от CrazySquirrel Посмотреть сообщение
    Простите, а зачем? Может лучше менять сайт и двигаться вперёд, чем ставить старый PHP и двигаться назад. Различия между 5.2 и 5.3 не такие большие..

    p.s. Слава Б-гу что у вас не на PHP 4 сайт.
    Может конечно и лучше, но познаний на данный момент в php у меня не много, в прочем как и в VDS под Linux Gentoo, а движек сайта последний раз продвигался и обновлялся в 2008г.., после чего проект прикрыли.. То есть нужно либо править код движка..(так как на 5.3 куча ошибок..,я проверял) либо даунгрейт до пыхпы 5.2

    мне кто то говорил, что как то через "emerge" это делается..
    То есть 5.3 версию замаскировать.., а 5.2 сделать емерджи анмаск..
    но так и не понял толком, как это делается)
    Последний раз редактировалось Focster; 27.09.2011 в 12:26.
    ..зачем мы живём.....?и я для чего...

  7. Вверх #7
    Постоялец форума Аватар для Lord of rings
    Пол
    Мужской
    Адрес
    Одесса, типа украина...
    Сообщений
    2,509
    Репутация
    148
    Так это..... если у тебя виртуальный сервер, и есть рут и SSH - проблем нет поставить хоть 10 версий PHP... но если ты не силен в этом, тогда наверное лучше и не трогай, а обратись к профильному админу.... например в то место, где сервер хостится.
    Per rectum ad astrum!

  8. Вверх #8
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    30
    Сообщений
    176
    Репутация
    21
    Цитата Сообщение от Lord of rings Посмотреть сообщение
    Так это..... если у тебя виртуальный сервер, и есть рут и SSH - проблем нет поставить хоть 10 версий PHP... но если ты не силен в этом, тогда наверное лучше и не трогай, а обратись к профильному админу.... например в то место, где сервер хостится.
    Обращался.. Мне сказали, что данные операции делает юзер сам..
    То есть они дают VDS, а ты твори что хочешь..

    Да, у меня есть рут и SSH но не знаю что делать..
    php я кажется отключил.., так как залил на сервер файлик phpinfo.php и раньше он показывал инфо о пхп, а сейчас код содержимое файлика появляется..
    ..зачем мы живём.....?и я для чего...

  9. Вверх #9
    Посетитель Аватар для jammin
    Пол
    Мужской
    Возраст
    32
    Сообщений
    431
    Репутация
    53
    Мой Вам совет - дайте объявление на форуме, найдите человека который это умеет и заплатите ему. Эта услуга вряд ли обойдется дорого, там работы на полчаса, за то если все пройдет нормально - будете иметь спеца на будущее, мало ли что.

  10. Вверх #10
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    30
    Сообщений
    176
    Репутация
    21
    Дело в том, что я ещё не покупал этот VDS - это тестовый 10ти дневной период сейчас.., но VDS не дорогой.., По этому возник вопрос.. Понижать php или брать другой vds т другой компании..
    ..зачем мы живём.....?и я для чего...

  11. Вверх #11
    Постоялец форума Аватар для Lord of rings
    Пол
    Мужской
    Адрес
    Одесса, типа украина...
    Сообщений
    2,509
    Репутация
    148
    а что, ресурс такой требоавательный , что ему VDS нужен?
    Per rectum ad astrum!

  12. Вверх #12
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    30
    Сообщений
    176
    Репутация
    21
    Там много приколов..
    нужно компилить через SSH даемон си+ daemon.cpp с поддержкой mod_voc2.c
    то есть нужен root ssh.. нужно php5.2 и MySql
    + конечно, лучше что бы были определённые постоянные размеры системных ресурсов..
    ..зачем мы живём.....?и я для чего...

  13. Вверх #13
    YUM стоит на сервере?

  14. Вверх #14
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    30
    Сообщений
    176
    Репутация
    21
    Цитата Сообщение от Comunity Посмотреть сообщение
    YUM стоит на сервере?
    Linux Gentoo

    Я с гугла так понял что "yum" это в линуксе.., а в Gentoo "emerge"


    "emerge" - есть и работает

    Вот что у меня стоит Linux vz3462 2.6.18-028stab056-aufs-teak-rin1 #27 SMP Wed Mar 9 23:31:49 EET 2011 i686
    Последний раз редактировалось Focster; 28.09.2011 в 00:16.
    ..зачем мы живём.....?и я для чего...

  15. Вверх #15
    Постоялец форума
    Пол
    Мужской
    Сообщений
    1,408
    Репутация
    385
    Код:
    emerge --sync
    emerge =dev-lang/php-5.2.17

  16. Вверх #16
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    30
    Сообщений
    176
    Репутация
    21
    Цитата Сообщение от GH Посмотреть сообщение
    Код:
    emerge --sync
    emerge =dev-lang/php-5.2.17
    !!! All ebuilds that could satisfy "=dev-lang/php-5.2.17" have been masked.
    !!! One of the following masked packages is required to complete your request:
    - dev-lang/php-5.2.17 (masked by: package.mask)
    /usr/portage/profiles/package.mask:
    # Ole Markus With <[email protected]> (21 Aug 2011)
    # Masking php:5.2. No longer maintained by upstream
    # Will be removed in a few months, depending on how much noise this will create


    For more information, see the MASKED PACKAGES section in the emerge
    man page or refer to the Gentoo Handbook.


    * IMPORTANT: 5 news items need reading for repository 'gentoo'.
    * Use eselect news to read news items.
    ..зачем мы живём.....?и я для чего...

  17. Вверх #17
    Постоялец форума
    Пол
    Мужской
    Сообщений
    1,408
    Репутация
    385
    Говорят, что устарел и скоро будет удален.

    Попробуйте:
    Код:
    echo "dev-lang/php" >> /etc/portage/package.keywords
    emerge =dev-lang/php-5.2.17

  18. Вверх #18
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    30
    Сообщений
    176
    Репутация
    21
    Цитата Сообщение от GH Посмотреть сообщение
    Говорят, что устарел и скоро будет удален.

    Попробуйте:
    Код:
    echo "dev-lang/php" >> /etc/portage/package.keywords
    emerge =dev-lang/php-5.2.17
      Показать скрытый текст
    SPOILER
    ..зачем мы живём.....?и я для чего...

  19. Вверх #19
    Постоялец форума
    Пол
    Мужской
    Сообщений
    1,408
    Репутация
    385
    Сделай на всякий случай:
    Код:
    emerge portage
    echo 'EMERGE_DEFAULT_OPTS="--autounmask=n"' >> /etc/make.conf
    echo dev-lang/php >> /etc/portage/package.unmask
    emerge =dev-lang/php-5.2.17
    Должно работать.

  20. Вверх #20
    Посетитель
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    30
    Сообщений
    176
    Репутация
    21
    Цитата Сообщение от GH Посмотреть сообщение
    Сделай на всякий случай:
    Код:
    emerge portage
    echo 'EMERGE_DEFAULT_OPTS="--autounmask=n"' >> /etc/make.conf
    echo dev-lang/php >> /etc/portage/package.unmask
    emerge =dev-lang/php-5.2.17
    Должно работать.
    Ввёл все эти команды..,вот 4й этап какой то установки идет.. уже час где то ))

    Ещё вопрос.. Я где то читал. что после отката пхп.., если система потом полезет в инет обновляться, то может снова обновить пхп до новой версии.., можно сделать, как то что бы не обновляла пхп?
    ..зачем мы живём.....?и я для чего...


Ответить в теме
Страница 1 из 2 1 2 ПоследняяПоследняя

Похожие темы

  1. Введение в PHP, MySQL
    от Anonymous в разделе Программирование
    Ответов: 81
    Последнее сообщение: 21.03.2015, 02:17
  2. Установка русского языка в Linux Slackware 10.0
    от Vintyara в разделе Программное обеспечение
    Ответов: 8
    Последнее сообщение: 16.05.2005, 10:03
  3. Давайте Linux'ами менятся...
    от stas1707 в разделе Программное обеспечение
    Ответов: 66
    Последнее сообщение: 27.02.2005, 03:22
  4. Linux-Форум уже доступен!!!
    от ase в разделе Программное обеспечение
    Ответов: 1
    Последнее сообщение: 29.05.2004, 19:27
  5. Кто у нас программирует на PHP?
    от iFog в разделе Программирование
    Ответов: 23
    Последнее сообщение: 10.03.2004, 17:35

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения