Одесса: 2°С (вода 8°С)
Киев: 0°С
Львов: -2°С

Тема: Проблема с переносом справочника!

Ответить в теме
Показано с 1 по 2 из 2
  1. Вверх #1
    Посетитель
    Пол
    Мужской
    Адрес
    пгт.Великодолинское
    Сообщений
    173
    Репутация
    21
    Записей в дневнике
    1

    По умолчанию Проблема с переносом справочника!

    Подключаюсь к базе 8.0 Ут с Базы 8.1 УТ такой процедурой:

    Процедура КнопкаВыполнитьНажатие(Кнопка)
    V8 = Новый COMОбъект("V8.Application");
    Попытка
    Открыта = V8.Connect("File=""E:\енннн"";Usr=""......."";Pwd= ""........"";")
    Исключение
    Предупреждение ("Ошибка открытия информационной базы");
    Возврат;
    КонецПопытки;
    Импорт = V8.NewObject("Справочник.Номенклатура");
    Импорт.Выбрать();
    Пока Импорт.Следующий() Цикл
    Если Не Импорт.ЭтоГруппа Тогда
    Сообщить(Импорт);
    КонецЕсли;
    КонецЦикла;


    Система выдает ошибку не определен тип Справочник.Контрагенты или Произошла исключительная ситуация!

    Помогите как исправить ошибку. Если есть у кого-то такая обработка то скиньте на мейл [email protected] Заранее очень благодарен.


  2. Вверх #2
    Ви мине устали
    Аватар для Бозон
    Пол
    Мужской
    Адрес
    Одесса
    Возраст
    63
    Сообщений
    38,523
    Репутация
    31056
    Цитата Сообщение от rusy_od Посмотреть сообщение
    Подключаюсь к базе 8.0 Ут с Базы 8.1 УТ такой процедурой:

    Процедура КнопкаВыполнитьНажатие(Кнопка)
    V8 = Новый COMОбъект("V8.Application");
    Попытка
    Открыта = V8.Connect("File=""E:\енннн"";Usr=""......."";Pwd= ""........"";")
    Исключение
    Предупреждение ("Ошибка открытия информационной базы");
    Возврат;
    КонецПопытки;
    Импорт = V8.NewObject("Справочник.Номенклатура");
    Импорт.Выбрать();
    Пока Импорт.Следующий() Цикл
    Если Не Импорт.ЭтоГруппа Тогда
    Сообщить(Импорт);
    КонецЕсли;
    КонецЦикла;


    Система выдает ошибку не определен тип Справочник.Контрагенты или Произошла исключительная ситуация!

    Помогите как исправить ошибку. Если есть у кого-то такая обработка то скиньте на мейл [email protected] Заранее очень благодарен.
    1. Согласовать конфигурации
    2. Выгрузить справочник стандартной обработкой Выгрузка и загрузка данных ХМЛ. Если ее нет в конфе- выдрать из УПП
    3. Наслаждацца

Ответить в теме

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения